Exchange 2019 findet nichts

Vor paar Tagen merkten wir in unserer Exchange 2019-Umgebung das seit dem Hafnium Patch die Suche in Outlook und in Outlook Web immer löchriger wurde. Suchbegriffe in Outlook wurden jeweils nur unvollständig angezeigt. In Outlook konnte man dies umgehen in dem man auf  „Unterordner“ durchsuchen klickte. Das kann aber nicht die Lösung sein.

Viel Recherche hat auch keine brauchbaren Ergebnisse geliefert wie das Problem zu lösen ist und die Suchresultate wieder alle Treffer anzeigen. Da in Exchange 2019 die Indexierung durch eine neue Technologie ersetzt wurde, liess sich  dies mit bekannten Mitteln nicht bewerkstelligen, da sich der Index nicht mehr einfach so neu erstellen lässt.

Was wir aber herausgefunden haben, wenn das Benutzerpostfach das davon betroffen ist, auf eine andere Datenbank verschoben wird, scheint sich der Index neu aufzubauen. Dies ist zwar keine Zufriedenstellende Lösung, aber im Moment die einzige. Ich hoffe das bei den verschobenen Postfächern nun das Problem der unvollständigen Suche nicht mehr auftritt.

 

 

Extensions PHP 8 – Windows

PHP 8 auf Windows Webserver bringt eine Tücke mit sich, dass die Extensions nicht geladen werden, auch wenn diese in der php.ini aktiviert wurden. Das hängt damit zusammen, dass unbedingt der Pfad zu den Extensions komplett angegeben werden muss. 

So sieht das in der php.ini aus:

;;;;;;;;;;;;;;;;;;;;;;;;;
; Paths and Directories ;
;;;;;;;;;;;;;;;;;;;;;;;;;

; On windows:
extension_dir = "C:\inetpub\php\8.0.6\ext\"

Natürlich muss der Pfad auf das entsprechende „Ext“ Verzeichnis zeigen.